In place upgrade to Windows 2019 from Windows 2016. Error 0xC1900101 – 0x30018 The installation failed in FIRST_BOOT phase with an error during SYSPREP operation. #windows2019 @MicrosoftHelps @Microsoft

Hi all!

This must be one of the first time that this happens, something about Windows in this blogg. But i felt like this must be shared.

I was doing in place upgrade from Windows 2016 to 2019. And some some servers went well and some got this message.

The upgrade went to about 52% and the failed.

The server rebooted and went back to 2016. I thought that all these server were alike but something was different.

How did I found how to fix this

I was reading this logfile:

($WINDOWS.~BT\Sources\Panther\setupact.log).

You can access this by viewing hidden files i C:\

The log file was big, 158MB

But i scrolled to the end and found some errors regarding RDPWEB.

So I looked closer at the servers. And all servers that had failed had for some reason RDP server installed. Why I did not know.

This can be by design if there really was RDP servers, but these servers where not. So thats why I could uninstall RDP.

I uninstalled RDP services and rebooted

Did the upgrade and it went fine!

Thanks for reading.

Keep hacking!

//Roger

2 Comments

  1. Nice – in that you’ve spotted the issue. Sadly that’s not vaguely practical in some scenarios so that’s going to need me to file a ticket with MS Support – but thanks for posting this.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.